$re = '/(www[.])?example[.]com/m';
$str = 'example.com -> www.example.net
www.example.com -> www.example.net
something.example.com
www
wwwexample.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);