#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)balancetonporc[^,\n]*"
Local $sString = "#balancetonPorc#%$%#$%^" & @CRLF & _
"#balancetonporc#%$%, text"
Local $sSubst = "BalanceTonPorc"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)