$re = '/balancetonporc[^,\n]*/i';
$str = '#balancetonPorc#%$%#$%^
#balancetonporc#%$%, text';
$subst = "BalanceTonPorc";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;