$re = '/^\d+(?:,\d+)*$/m';
$str = '9
9,65
1,2,4,55,4
,545
76657,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);