using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"4([0-9]){3} ([0-9]{4} ){2}([0-9]{4})";
string input = @"4000 0012 3456 7890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}