$re = '/4([0-9]){3} ([0-9]{4} ){2}([0-9]{4})/m';
$str = '4000 0012 3456 7890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);