using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]+)( )?\/( )?(([0-9\/]+))";
string input = @" + 25/50/75/100/125/150/175 ед.
+ 25 /50/75/100/125 /150/ 175 ед.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}