re = /([0-9]+)( )?\/( )?(([0-9\/]+))/m
str = ' + 25/50/75/100/125/150/175 ед.
+ 25 /50/75/100/125 /150/ 175 ед.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end