package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-1]?[0-9]|2[0-4]):([0-5][0-9])(:[0-5][0-9])?$`)
var str = `02:05
23:50
14:28
25:00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}