const regex = new RegExp('!php/const[:\\s]\\s*(.*)(\\s*)', 'g')
const str = `parameters:
class_constant: !php/const Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::TEST
class: !php/const Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::class
class2: !php/const:Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::class
const: !php/const PHP_INT_MAX
const2: !php/const:PHP_INT_MAX
unexisting_constant: !php/const SomeClass::Constant
!php/const PHP_INT_MAX: some_value
!php/const App\\Entity\\Plant::TRANSITION_PLANT: some_value
!php/const:App\\Entity\\Plant::TRANSITION_TWO: some_value`;
const subst = `%const($1)$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);