// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"!php/const[:\s]\s*(.*)(\s*)").unwrap();
let string = "parameters:
class_constant: !php/const Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::TEST
class: !php/const Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::class
class2: !php/const:Symplify\\ConfigTransformer\\Tests\\Converter\\ConfigFormatConverter\\YamlToPhp\\YamlToPhpTest::class
const: !php/const PHP_INT_MAX
const2: !php/const:PHP_INT_MAX
unexisting_constant: !php/const SomeClass::Constant
!php/const PHP_INT_MAX: some_value
!php/const App\\Entity\\Plant::TRANSITION_PLANT: some_value
!php/const:App\\Entity\\Plant::TRANSITION_TWO: some_value";
let substitution = "%const($1)$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}