import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(Where|How|Is|Does|I wanna|I want|I wish)\\b.*\\bdemo( game| version( of the game)?)?( exist| available| out there)?(\\.|\\?|!)*?$";
final String string = "How can I download the demo\n"
+ "Where get demo?!?!\n"
+ "where is the demo version of the game?\n"
+ "How do I get the demo game!\n"
+ "Anyone know how to get the demo?\n"
+ "How does one download a geneshit\n"
+ "so I was wondering, how do we get more newbies to play the demo\n"
+ "Does a demo version of the game exist?!?!?\n"
+ "Is a demo version of the game available\n"
+ "is a demo version of the game out there\n"
+ "Is there a demo version?\n"
+ "I wish there was a demo version\n"
+ "is a demo out there?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}