$re = '/(?<= )[^ \]]+(?=\[)/m';
$str = '<30>2024-04-02T19:58:10.002Z xxxxxxxx dhclient-uw[xxxxxx]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);