re = /(?<= )[^ \]]+(?=\[)/m
str = '<30>2024-04-02T19:58:10.002Z xxxxxxxx dhclient-uw[xxxxxx]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end