$re = '/(?<=^.{70}\S*)\s+/m';
$str = 'hello i am a very long string that needs to be split into two differe parts! thank you so much for helping
hello i am a very long string that needs to be split into two different parts! thank you so much for helping';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);