re = /(?<=^.{70}\S*)\s+/m
str = 'hello i am a very long string that needs to be split into two differe parts! thank you so much for helping
hello i am a very long string that needs to be split into two different parts! thank you so much for helping'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end