use strict;
my $str = '[ ! [some tex!t !]
[som!e text !
!some text !
] ! foobar';
my $regex = qr/(\[[^[\]\n]*\])|!/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";