$re = '/(\[[^[\]\n]*\])|!/m';
$str = '[ ! [some tex!t !]
[som!e text !
!some text !
] ! foobar';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;