import Foundation
let pattern = #"(?<host>[\w\-]+)(?=\.fully\.qualified\.domain\.name\.com).*?\b(?<ip>(?:(?:2(?:[0-4][0-9]|5[0-5])|[0-1]?[0-9]?[0-9])\.){3}(?:(?:2([0-4][0-9]|5[0-5])|[0-1]?[0-9]?[0-9])))\b.*?(?<filename>[a-zA-Z]:\\(?:[^\\\/:*?"<>|\r\n]+\\)*[^\\\/:*?"<>|\r\n]*)(?=<br\s*\/?>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
<td class="#ffffff" style=" " colspan="1">DNS Name:</td> <td class="#ffffff" style=" " colspan="1">comp-uter-123.fully.qualified.domain.name.com</td>
<snip few lines of crap>
<td class="#ffffff" style=" " colspan="1">IP:</td> <td class="#ffffff" style=" " colspan="1">10.0.0.10</td>
<snip like 150 lines of BS>
And then there's between 1 and maybe 50 of the below.
<h2>tcp/445/cifs</h2> <div class="clear"></div> <div style="box-sizing: border-box; width: 100%; background: #eee; font-family: monospace; padding: 20px; margin: 5px 0 20px 0;"> <br> Path : C:\Users\username\dir1\dir2\dir3\dir4\filename.exe<br> Installed version : 1.2.12<div class="clear"></div>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)