const regex = /^\d\d?(?:-\d\d?){2}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d\\d?(?:-\\d\\d?){2}$', 'gmi')
const str = `1-10-1
1-7-3
10-8-5
1-7-14
11-10-12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}