$re = '/^\d\d?(?:-\d\d?){2}$/mi';
$str = '1-10-1
1-7-3
10-8-5
1-7-14
11-10-12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);