package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z].*-[0-9].*`)
var str = `ALP-098
-987
ALP-7
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}