$re = '/[A-Z].*-[0-9].*/m';
$str = 'ALP-098
-987
ALP-7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);