$re = '/^https?:\/\/[^\/]+\/[^?]+(\?[^=&]+=[^&]+)?$/';
$str = 'https://anything1/folder/index.html?param=anything2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);