re = /^https?:\/\/[^\/]+\/[^?]+(\?[^=&]+=[^&]+)?$/
str = 'https://anything1/folder/index.html?param=anything2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end