import re
regex = re.compile(r"<p>(.*?)<\/p>.*?<span>((?!CHEESE).*?)<\/span>.*?<\/div>", flags=re.MULTILINE | re.DOTALL)
test_str = ("<div><p>HELLO1</p>\n"
" <span>SPIDER</span></div>\n"
" <div><p>HELLO2</p>\n"
" <span>CHEESE</span></div>\n"
" <div><p>HELLO3</p>\n"
" <span>BANANA</span></div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")