package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{6}((-?|_?)[a-zA-Z0-9])+$`)
var str = `201811test0-1test02-test123`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}