$re = '/^\d{6}((-?|_?)[a-zA-Z0-9])+$/';
$str = '201811test0-1test02-test123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);