package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(pp\. \d+(?:-\d+)?\)|\b\d+-\d+\b`)
var str = `- Mitchell, J.A. (2017). Citation: Why is it so important. Mendeley Journal, 67(2), (pp. 81-95).
- Denhart, H. (2008). Deconstructing barriers: Perceptions of students labeled with learning disabilities in higher education. Journal of Learning Disabilities, 41, 483-497.
(pp. 81). `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}