re = /\(pp\. \d+(?:-\d+)?\)|\b\d+-\d+\b/m
str = '- Mitchell, J.A. (2017). Citation: Why is it so important. Mendeley Journal, 67(2), (pp. 81-95).
- Denhart, H. (2008). Deconstructing barriers: Perceptions of students labeled with learning disabilities in higher education. Journal of Learning Disabilities, 41, 483-497.
(pp. 81). '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end