using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *""(\w+)"": (""?[^,""]*""?)[,|,\n]";
string input = @" ""ID"": 26,
""MenuName"": ""测点数据管理"",
""PLevel"": 2,
""Url"": ""pages/datamanage/sensor_group/index.html"",
""NewTab"": 0,
""IconName"": "",
""ParentID"": 23,
""OrderBy"": 5,
""Remark"": "",
""MenuType"": 2,
""RoleID"": 1,
""PagePower"": 1,
""MenuID"": ""26"",
""ButtonName"": ""添加数据"",
""ButtonID"": ""addSensorOrgData"",
""FunctionName"": ""addSensorOrgDataByID"",
""FunctionController"": ""sensordata"",
""OrderBy"": 5,
""RoleID"": 1,
""MenuType"": 3,
""MenuID"": 1,
""ParentID"": 26,
""MenuName"": ""添加数据"",
""PagePower"": 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}