const regex = / *"(\w+)": ("?[^,"]*"?)[,|,\n]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' *"(\\w+)": ("?[^,"]*"?)[,|,\\n]', 'gm')
const str = ` "ID": 26,
"MenuName": "测点数据管理",
"PLevel": 2,
"Url": "pages/datamanage/sensor_group/index.html",
"NewTab": 0,
"IconName": "",
"ParentID": 23,
"OrderBy": 5,
"Remark": "",
"MenuType": 2,
"RoleID": 1,
"PagePower": 1,
"MenuID": "26",
"ButtonName": "添加数据",
"ButtonID": "addSensorOrgData",
"FunctionName": "addSensorOrgDataByID",
"FunctionController": "sensordata",
"OrderBy": 5,
"RoleID": 1,
"MenuType": 3,
"MenuID": 1,
"ParentID": 26,
"MenuName": "添加数据",
"PagePower": 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}