package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+[\/-](.+)\.png`)
var str = `https://stardewvalleywiki.com/mediawiki/images/thumb/b/b1/Dandelion.png/24px-Dandelion.png
https://stardewvalleywiki.com/mediawiki/images/8/8a/Spring_Foraging_Bundle.png
https://stardewvalleywiki.com/mediawiki/images/thumb/9/94/Speed-Gro.png/24px-Speed-Gro.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}