re = /.+[\/-](.+)\.png/m
str = 'https://stardewvalleywiki.com/mediawiki/images/thumb/b/b1/Dandelion.png/24px-Dandelion.png
https://stardewvalleywiki.com/mediawiki/images/8/8a/Spring_Foraging_Bundle.png
https://stardewvalleywiki.com/mediawiki/images/thumb/9/94/Speed-Gro.png/24px-Speed-Gro.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end