using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((http|https)\:\/\/)?[a-zA-Z0-9\.\/\?\:@\-_=#]+\.([a-zA-Z0-9\&\/\?\:@\-_=#])+";
string input = @"www.something.com.
www.something.com</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}