package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http|https)\:\/\/)?[a-zA-Z0-9\.\/\?\:@\-_=#]+\.([a-zA-Z0-9\&\/\?\:@\-_=#])+`)
var str = `www.something.com.
www.something.com</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}