#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.? *(?:\[[^]]+\]|\w+)"
Local $sString = "Schema.TableName" & @CRLF & _
"Schema . TableName" & @CRLF & _
"[Schema].[TableName]" & @CRLF & _
"[Schema] . [TableName]" & @CRLF & _
"Schema. [TableName]" & @CRLF & _
"[SchemaPart1.Part2.Part 3].[Table . Name]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")