re = /\.? *(?:\[[^]]+\]|\w+)/m
str = 'Schema.TableName
Schema . TableName
[Schema].[TableName]
[Schema] . [TableName]
Schema. [TableName]
[SchemaPart1.Part2.Part 3].[Table . Name]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end