import re
regex = re.compile(r"(?<=data-rlocation=\").*?(?=\")", flags=re.MULTILINE)
test_str = "<p class=\"sm clg\" data-rlocation=\"Uttam Nagar East\">Uttam Nagar East, Delhi <span class=\"to-txt\" id=\"citytt1\">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")