re = /(?<=data-rlocation=").*?(?=")/m
str = '<p class="sm clg" data-rlocation="Uttam Nagar East">Uttam Nagar East, Delhi <span class="to-txt" id="citytt1">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end