$re = '/(?:\[(?=[^[\]]*])|\G(?!^))[^;[\]]*\K;/';
$str = '["Text1;Text2;....;TextN"];asjkdjksd;ajksdjksad["Text1;Text2;....;TextN"]
.["Text1;Text2"]...long text...["Text1;Text2;Text3"]....long text...["Text1;...;TextN"]...long text...
I ONLY want to change the ";" in the ["Text1;...;TextN"]
."Text1;Text2"]';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;