import Foundation
let pattern = #"(?:\[(?=[^[\]]*])|\G(?!^))[^;[\]]*\K;"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
["Text1;Text2;....;TextN"];asjkdjksd;ajksdjksad["Text1;Text2;....;TextN"]
.["Text1;Text2"]...long text...["Text1;Text2;Text3"]....long text...["Text1;...;TextN"]...long text...
I ONLY want to change the ";" in the ["Text1;...;TextN"]
."Text1;Text2"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)