package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d[\d \t,.]*(?:carpet|sft|feet|sqft|yard|gaj|feet|s\.ft|sq\.ft|sq feet|fq\.ft\.|sq\.ft\.|pt|crpt|ft|sq\.mt\.|sq\.mtr|sq\.mt|plot|sf|sfqt|acer|gj|vigha|anna|gunta|sq|gunthe|guntha|bigha|sqd|sqm|sqyd|area|acre|square|yrd|sq\.yard|sq yd|sq\.yd|sq\. yd\.|gaj|sqt)s?`)
var str = `kanakiya area 1350 sqft asking price : 95 lacs destination properties azymn - 9920902674
plot on rent near sp ring road rajpath club ki gali me road touch 5000 war na 350000 rent owner side no b
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}