import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d[\\d \\t,.]*(?:carpet|sft|feet|sqft|yard|gaj|feet|s\\.ft|sq\\.ft|sq feet|fq\\.ft\\.|sq\\.ft\\.|pt|crpt|ft|sq\\.mt\\.|sq\\.mtr|sq\\.mt|plot|sf|sfqt|acer|gj|vigha|anna|gunta|sq|gunthe|guntha|bigha|sqd|sqm|sqyd|area|acre|square|yrd|sq\\.yard|sq yd|sq\\.yd|sq\\. yd\\.|gaj|sqt)s?";
final String string = "kanakiya area 1350 sqft asking price : 95 lacs destination properties azymn - 9920902674 \n"
+ " plot on rent near sp ring road rajpath club ki gali me road touch 5000 war na 350000 rent owner side no b\n\n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}