$re = '/^([^,@\n]+)(?:,([^,@\n]+))?(?:@(.+))?$/m';
$str = '12345,abcd@ABCD
12345,abcd
12345@ABCD
12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);