re = /^([^,@\n]+)(?:,([^,@\n]+))?(?:@(.+))?$/m
str = '12345,abcd@ABCD
12345,abcd
12345@ABCD
12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end