using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^:(?![^:]*([^:])[^:]*\1)[dgimsuy]{0,7}:$";
string input = @"::
:g:
:d:
:i:
:m:
:s:
:u:
:y:
:dg:
:gi:
:ms:
:uy:
:sd:
:mu:
:yi:
:dgi:
:gms:
:iuy:
:sdm:
:ymu:
:dgim:
:gims:
:iysu:
:msuy:
:dgims:
:gimsu:
:iysum:
:mugsy:
:dsygiu:
:gsiumd:
:ydsugi:
:isgumy:
:mugydi:
:ysgmdi:
:sgydmi:
:yigdsm:
:mudysg:
:gsdiuy:
:digmsuy:
:sudgimy:
:ydugsim:
:mudyisg:
:sgimydu:
:ysgidum:
:muidsyg:
:gusdymi:
:yidgums:
:sugmidy:
:gg:
:dd:
:ii:
:mm:
:ss:
:uu:
:yy:
:dgg:
:idd:
:iig:
:mmm:
:sms:
:uuu:
:yyy:
:dggi:
:iddd:
:iigm:
:mmmm:
:smss:
:uuuu:
:yyyy:
:dggiu:
:idddm:
:iigmy:
:mmmms:
:smsss:
:uuuuy:
:yyyym:
:dgimsguy:
:ydsgimuy:
:dgimsuyy:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}