import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^:(?![^:]*([^:])[^:]*\\1)[dgimsuy]{0,7}:$";
final String string = "::\n"
+ ":g:\n"
+ ":d:\n"
+ ":i:\n"
+ ":m:\n"
+ ":s:\n"
+ ":u:\n"
+ ":y:\n"
+ ":dg:\n"
+ ":gi:\n"
+ ":ms:\n"
+ ":uy:\n"
+ ":sd:\n"
+ ":mu:\n"
+ ":yi:\n"
+ ":dgi:\n"
+ ":gms:\n"
+ ":iuy:\n"
+ ":sdm:\n"
+ ":ymu:\n"
+ ":dgim:\n"
+ ":gims:\n"
+ ":iysu:\n"
+ ":msuy:\n"
+ ":dgims:\n"
+ ":gimsu:\n"
+ ":iysum:\n"
+ ":mugsy:\n"
+ ":dsygiu:\n"
+ ":gsiumd:\n"
+ ":ydsugi:\n"
+ ":isgumy:\n"
+ ":mugydi:\n"
+ ":ysgmdi:\n"
+ ":sgydmi:\n"
+ ":yigdsm:\n"
+ ":mudysg:\n"
+ ":gsdiuy:\n"
+ ":digmsuy:\n"
+ ":sudgimy:\n"
+ ":ydugsim:\n"
+ ":mudyisg:\n"
+ ":sgimydu:\n"
+ ":ysgidum:\n"
+ ":muidsyg:\n"
+ ":gusdymi:\n"
+ ":yidgums:\n"
+ ":sugmidy:\n\n"
+ ":gg:\n"
+ ":dd:\n"
+ ":ii:\n"
+ ":mm:\n"
+ ":ss:\n"
+ ":uu:\n"
+ ":yy:\n"
+ ":dgg:\n"
+ ":idd:\n"
+ ":iig:\n"
+ ":mmm:\n"
+ ":sms:\n"
+ ":uuu:\n"
+ ":yyy:\n"
+ ":dggi:\n"
+ ":iddd:\n"
+ ":iigm:\n"
+ ":mmmm:\n"
+ ":smss:\n"
+ ":uuuu:\n"
+ ":yyyy:\n"
+ ":dggiu:\n"
+ ":idddm:\n"
+ ":iigmy:\n"
+ ":mmmms:\n"
+ ":smsss:\n"
+ ":uuuuy:\n"
+ ":yyyym:\n"
+ ":dgimsguy:\n"
+ ":ydsgimuy:\n"
+ ":dgimsuyy:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}