#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\([]?([0-9]{3})[\)\]]?[-. ]?[\([]?([0-9]{3})[\)\]]?[-. ]?[\([]?([0-9]{4})[\)\]]?|([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])"
Local $sString = "Yes I understand that, but in reality, when I try to run '987 654 3210' or '987-654-3210' or '987.654.3210', it does not work." & @CRLF & _
"" & @CRLF & _
"987 654 3210" & @CRLF & _
"" & @CRLF & _
"9 8 7 6 5 4 3 2 1 0" & @CRLF & _
"" & @CRLF & _
"(987) 654 3210" & @CRLF & _
"" & @CRLF & _
"(987) (654) (3210)" & @CRLF & _
"" & @CRLF & _
"987.654-3210" & @CRLF & _
"" & @CRLF & _
"9 8 7.6-5-4.3 2 1 0" & @CRLF & _
"" & @CRLF & _
"[987] 654 3210" & @CRLF & _
"" & @CRLF & _
"(987)-(654).(3210)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")