import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\([]?([0-9]{3})[\\)\\]]?[-. ]?[\\([]?([0-9]{3})[\\)\\]]?[-. ]?[\\([]?([0-9]{4})[\\)\\]]?|([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])[-. ]([0-9])";
final String string = "Yes I understand that, but in reality, when I try to run '987 654 3210' or '987-654-3210' or '987.654.3210', it does not work.\n\n"
+ "987 654 3210\n\n"
+ "9 8 7 6 5 4 3 2 1 0\n\n"
+ "(987) 654 3210\n\n"
+ "(987) (654) (3210)\n\n"
+ "987.654-3210\n\n"
+ "9 8 7.6-5-4.3 2 1 0\n\n"
+ "[987] 654 3210\n\n"
+ "(987)-(654).(3210)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}